iPad Pro 1876 won’t...
Clear all

iPad Pro 1876 won’t charge unless through usb C to C

1 Posts
1 Users
New Member Guest
Joined: 4 weeks ago
Posts: 1
Topic starter  

I have an iPad Pro 2018 12.9inch,a personal one and not from a customer.

I bought it with a broken charging port so I quickly bought a new charging flex cable and replaced it cause the old flex cable pins where touching each other..so after replacing the flex cable..

it doesn’t charge with the quote” not charging” at the top. I tried a usb C to C cable and it changed normally.used a regular usb and it won’t charge.

it’s currently in iPad disable state and I need to restore but it doesn’t get detected by Pc..

even if I tried with the USB C to C on PC it only charges and the PC won’t be able to detect it.

I tried same flex I bought on another iPad with same model and regular cable charge and gets detected by Pc and also charge and gets detected on type C to C cable..

so it’s definitely not the flex cause I even swapped with the other iPad that they had not been changed and same problem..


the main issue I have is it can’t be detected by PC and I needed to restore it from the iPad disabled state..

what do u think is the problem..

IS THE TRISTAR chip or the USB C controller chip.

some something else on the mother board 


Leave a reply

Author Name

Author Email

Title *

Maximum allowed file size is 10MB

Preview 0 Revisions Saved