Main Repair Questions Razer Blade 17 no power

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #11120
    CiscoJunkie
    Participant
      • Topics 1
      • Replies 0
      • Total 1
      • New Member

      My Blade RC30-0287 battery bloated two weeks ago to the point i saw a warning on the screen my machine was about to turn off. Afterwards, i could not power on the laptop with/wo external power plugged in. So, being outside of warranty, i ordered a replacement battery with the fan shroud attached as an all-in-one replacement. This battery looks clean and in working condition, but when i plugged it in, the power button does nothing with/wo external power plugged in. Power brick has green light and thought, ok i have a bad battery again i guess. Submitted a return through eBay and ordered another battery from a different seller.

      When i installed this battery temporally to check if the power button would do anything, i saw the keyboard light up and the screen came on to bios. So i turned off the machine, disconnected the battery to get it aligned right with the screw holes and when i plugged in the power connector for the battery to the board, i saw a white flash on the left side of the connector inside..no sparks. I was like ok great, somehow this battery is dead now or my motherboard is somehow eating up batteries.

      I then pulled everything apart for inspection and see no components blown, no black markings or signs of anything blowing, and unable to figure out what is going on with my power path.

      Any schematic for testing the power path on this machine, or at least a pinout for the battery connector to test the battery itself? in dire need at this point as my tshoot skills which should have led to me finding a blown component or some cause to this problem have led me nowhere.

      Looking through the excellent videos on the YouTube channel now to maybe get some new areas to check. I assume since i cannot power on the laptop with external power plugged in and battery out that i have a board issue?

      *memory, SSDs and Wifi removed in picture*
      *top right is the power connector side with the 3 posts on board*

      • This topic was modified 1 month, 3 weeks ago by CiscoJunkie.
      • This topic was modified 1 month, 3 weeks ago by CiscoJunkie.
      #11167
      urad29
      Participant
        • Topics 1
        • Replies 1
        • Total 2
        • New Member

        Hi,
        Some laptops do not power on through the charging cable unless the battery is plugged in as well. Let me know what happens.

      Viewing 2 posts - 1 through 2 (of 2 total)
      • You must be logged in to reply to this topic.