Main Repair Questions I Charge Pro Fast Charge (the charger Alex uses on his desk) need a photo

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #10609
    charliecrackle
    Participant
      • Topics 1
      • Replies 3
      • Total 4
      • New Member

      I bought a I Charge Pro Fast Charge and had it fail due to over current (I thought it was protected against that)
      The port that failed is the Green QC port. I have taken apart and fixed this but it will only charge at 5V the data pins traces are broken.
      I need a photo of the Circuit board so I can see where these traces go as mine is too damaged
      I have been asking alex if he could spare 5 minutes to do this for me but he can not.
      I have attached pictures of how you remove the front cover with out damage and the area of the board I need a photo of. If any one else has bought one of these and could take a photo It would be greatly appreciated. See attached photos.

      #10627
      Ped
      Participant
        • Topics 0
        • Replies 6
        • Total 6
        • New Member

        I’ll see if mine is the same when I’m in work tomorrow. Take note, the resistor in that pic (marked R050) and the rest of them on the board with the same markings are current sense resistors and are prone to failing. I’ve had to replace mine.

        Regards

        #10680
        charliecrackle
        Participant
          • Topics 1
          • Replies 3
          • Total 4
          • New Member

          Thank you. looks like the current sense resistor just died and burnt the board. Is is the one that alex has on his desk. (see attached)

          you just need to push on the sides and the front pops off..

          Attachments:
          #10704
          Ped
          Participant
            • Topics 0
            • Replies 6
            • Total 6
            • New Member

            There should be two 1/2 ohm resistors there, they always burn out, just like they did on mine, just poor design. Replace them with half watt resistors (.5R).

            Attachments:
            #10928
            charliecrackle
            Participant
              • Topics 1
              • Replies 3
              • Total 4
              • New Member

              Thank you for the picture this is what I needed.

              #12572
              charliecrackle
              Participant
                • Topics 1
                • Replies 3
                • Total 4
                • New Member

                I got this working the Green QC port now Fast charging 5.0v @2.1 A but it is not changing to 9V as it used to.. it must not be negotiating correctly something is blown. any idea what chip /mosfet controls the voltage boost ??

              Viewing 6 posts - 1 through 6 (of 6 total)
              • You must be logged in to reply to this topic.